Partial outage for the Self Service APIs
Incident Report for OneCloud Inc
Resolved
This incident has now been resolved. Within the timeframe of 6:00 AM EDT - 12:00 PM EDT the Self Service APIs were affected 3 times. Each time, the Self Service APIs were unavailable for approximately 10 minutes. The incident times are listed below:

6:36 AM EDT
7:05 AM EDT
9:34 AM EDT

The cause of these outages was an application-level error that would crash the service that powers the Self Service APIs. We have since fixed that issue and added additional fail-safes to prevent a re-occurrence in the future. During these outages, no data was lost, but some scheduled chains may have failed to execute, and manually executed chains would not have been able to be started.

We apologize for the inconvenience and the disruption to your service provided by OneCloud. While we have fixed this issue now and in the future, we will be doing a full investigation into the cause and ways we can improve upon our processes to ensure unexpected outages like this do not continue in the future.

Thank you for being a valued OneCloud customer.
Posted Oct 13, 2020 - 16:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 13, 2020 - 15:51 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 13, 2020 - 15:44 UTC
Investigating
We are currently investigating this issue.
Posted Oct 13, 2020 - 13:41 UTC
This incident affected: OneCloud Self-Service APIs.