Document Platform unavailable
Incident Report for Workiva
Resolved
Between 3:00pm CDT and 3:50pm CDT customers may have experienced latency and instability with the Workiva documents platform. Reports show that the incident is now resolved. However, if you continue to experience any issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Mar 21, 2024 - 22:34 UTC
Update
We continue to observe and monitor recovery in the platform. We will provide an update as soon as possible.
Posted Mar 21, 2024 - 21:04 UTC
Monitoring
We are currently investigating reports that some users are experiencing low performance/unavailability in the document platform. We are aware of the intermittent latency in documents and actively working on a fix. We will provide an update as soon as possible.
Posted Mar 21, 2024 - 20:18 UTC
This incident affected: Workiva Platform (US) (Productivity (Documents, Spreadsheets, Charts, Presentations)).